Issue:
- Flashing lights/LEDs on display
- Filter light or filter icon is lit
- “F” shown on display
- Filter alarm shown on display
Applies to:
- Cooker hood/extractor fan
Resolution:
1. Switch off the power to the cooker hood.
2. Remove filter(s) from the cooker hood.
3. Clean or replace filter(s) as shown in the user manual.
Download the user manual.
Suitable filters as well as cleaning and care products are available on our Webshop.
4. Insert the clean filter.
5. Reset the filter alarm.
See your user manual for instructions on how to reset the filter alarm.
6. Contact an Authorized Service Center.
If the above suggestions did not solve the problem, we recommend requesting a visit by a service engineer.
Cause:
- The reason that the cooker hood might indicate that one or more filters should be cleaned/replaced is that the expected service life of the filter has been reached and it must be cleaned or replaced.
- You can optimise the cooker hood’s performance by switching it on approx. 15 minutes before you start cooking. This way, suction will form in the room and the cooker hood will be more readily able to remove vapours and odours.
- You can avoid having to use higher fan speeds by switching the cooker hood on before you start cooking, thus also minimising noise from the cooker hood.